Cisco - передача пин-кода при транзитном звонке IP->PSTN

Обсуждение оборудования Cisco Systems

Cisco - передача пин-кода при транзитном звонке IP->PSTN

Сообщение msotnikov » Вт авг 25, 2009 5:41 pm

Приветствую всех.
Чтение документации помогает, но не полностью.
Есть рабочая 3825. Звонки в город и т.д. настроены и работают, через 9.
Необходимо сделать альтернативный выход на междугородную линию, через еще одного провайдера, по уже существующей линии.
Звонок идет сначала на их пул, где вводится пин-код и потом туда передается номер.
Что сделал:
На Cisco Unified CallManager 4.2 , добавил Route Pattern - 6! National 192.168.10.2 (это адрес 3825)
Срабатывает, перенаправляет.
На 3825, добавил следующее:
!
voice translation-rule 9
rule 1 /^6\(.*\)/ /3630118,,пин-код,\1/
!
voice translation-profile OUT-ALFA
translate called 9
!
dial-peer voice 12 pots
description Test outgoing through ALFA
translation-profile outgoing OUT-ALFA
destination-pattern 6T
port 0/0/1:15
forward-digits all
!

При потытке звонка на мобильный номер, срабатывает голосовой автоинформатор (соединение с набранным номером не может быть установлено и т.д.) Если в dial-peer, поменять порт на port 0/0/0:15, то соединение вообще, сразу рвется и все.
Комманда sh call hi voi com, выдает:
1788777 ORG T0 None TELE P3630118,,пин-код,100 D1
1788776 ANS T0 g729r8 pre- VOIP P3605 0.0.0.0:0 D1

Подскажите, что и где надо поменять? Пробовал вместо нового диал-пира, просто rule 1 /^6\(.*\)/ /3630118,,пин-код,\1/ включить, как rule 2 в уже существующее правило (voice translation-rule 1), результат тот же.

Конфиг следующий:

version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname VoGW
!
boot-start-marker
boot-end-marker
!
card type e1 0 0
card type e1 0 1
enable secret 5 $1$4H8w$p9l8f9ldKy8mf6gF3/88Q0
!
no aaa new-model
clock timezone MSK 3
clock summer-time MSK recurring last Sun Mar 2:00 last Sun Oct 3:00
network-clock-participate wic 0
network-clock-participate wic 1
network-clock-select 1 E1 0/0/0
network-clock-select 2 E1 0/0/1
network-clock-select 3 E1 0/1/0
ip cef
!
!
!
!
no ip domain lookup
ip domain name domain.ru
isdn switch-type primary-net5
voice-card 0
dspfarm
!
!
!
!
voice service voip
h323
!
!
voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g729r8
!
!
!
!
!
!
!
!
voice translation-rule 1
rule 1 /^9/ //
!
voice translation-rule 2
rule 1 /^..../ /7975662/
!
voice translation-rule 3
rule 1 /^7975660/ /3160/
rule 2 /^7975664/ /2200/
rule 3 /^7975663/ /4001/
!
voice translation-rule 4
rule 1 /^..../ /7975665/
!
voice translation-rule 5
rule 1 /495/ /9/
rule 2 /9/ /989/
!
voice translation-rule 6
rule 1 /^0800/ //
!
voice translation-rule 7
rule 1 /^1/ //
!
voice translation-rule 8
rule 1 /^0/ /00000/
rule 2 /^1/ /00001/
rule 3 /^2/ /00002/
rule 4 /^3/ /00003/
rule 5 /^4/ /00004/
rule 6 /^5/ /00005/
rule 7 /^6/ /00006/
rule 8 /^7/ /00007/
rule 9 /^8/ /00008/
rule 10 /^9/ /00009/
!
voice translation-rule 9
rule 1 /^6\(.*\)/ /3630118,,пин-код,\1/
!
!
voice translation-profile IN
translate called 3
!
voice translation-profile IN-MTS
translate called 6
!
voice translation-profile Minfin
translate calling 8
!
voice translation-profile OUT
translate calling 2
translate called 1
!
voice translation-profile OUT-2
translate calling 4
!
voice translation-profile OUT-ALFA
translate called 9
!
voice translation-profile OUT-MTS
translate called 7
!
voice translation-profile TOCCM
translate calling 5
!
!
!
application
service IVR flash:unicon.tcl
!
service SAP flash:sap.tcl
!
!
!
!
username cisco privilege 0 secret 5 $1$KMvF$gXP0jSq0qXkCbJooZEdC7.
!
!
controller E1 0/0/0
framing NO-CRC4
pri-group timeslots 1-31
!
controller E1 0/0/1
framing NO-CRC4
pri-group timeslots 1-31
!
controller E1 0/1/0
framing NO-CRC4
pri-group timeslots 2-27
!
controller E1 0/1/1
shutdown
!
translation-rule 507
!
!
!
!
interface GigabitEthernet0/0
ip address 192.168.10.2 255.255.0.0
ip access-group 100 in
duplex auto
speed auto
media-type rj45
no keepalive
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
media-type rj45
no keepalive
!
interface Serial0/0/0:15
no ip address
encapsulation hdlc
no logging event link-status
isdn switch-type primary-net5
isdn incoming-voice voice
isdn negotiate-bchan resend-setup
no cdp enable
!
interface Serial0/0/1:15
no ip address
encapsulation hdlc
no logging event link-status
isdn switch-type primary-net5
isdn incoming-voice voice
isdn negotiate-bchan resend-setup
no cdp enable
!
interface Serial0/1/0:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn incoming-voice voice
no cdp enable
!
ip route 0.0.0.0 0.0.0.0 192.168.0.2
!
!
ip http server
no ip http secure-server
!
logging trap debugging
logging facility local2
листы вырезал, а то их много слишком
...
...
...
access-list 100 permit ip any any
snmp-server community ******* RO 20
!
!
!
control-plane
!
!
!
voice-port 0/0/0:15
!
voice-port 0/1/0:15
!
voice-port 0/0/1:15
!
!
!
!
dspfarm profile 1 transcode
shutdown
!
!
dial-peer voice 100 pots
description Outgoing Dial-peer for 7975662
translation-profile outgoing OUT
destination-pattern 9T
port 0/0/0:15
forward-digits all
!
dial-peer voice 1 pots
service ivr
incoming called-number 7975662
port 0/0/0:15
!
dial-peer voice 2 pots
service ivr
incoming called-number 7975665
port 0/0/1:15
!
dial-peer voice 101 pots
translation-profile outgoing OUT-2
destination-pattern 9T
port 0/0/1:15
forward-digits all
!
dial-peer voice 3 pots
description Incoming FAX number
translation-profile incoming IN
incoming called-number 7975660
direct-inward-dial
port 0/0/1:15
!
dial-peer voice 4 pots
description Line for 2200
translation-profile incoming IN
incoming called-number 7975664
direct-inward-dial
port 0/0/1:15
!
dial-peer voice 5 pots
service ivr
incoming called-number 4957975662
port 0/0/0:15
!
dial-peer voice 6 pots
service ivr
incoming called-number 4957975665
port 0/0/1:15
!
dial-peer voice 7 pots
translation-profile incoming Minfin
service sap
incoming called-number 7975661
port 0/0/1:15
!
dial-peer voice 8 pots
translation-profile incoming Minfin
service sap
incoming called-number 4957975661
port 0/0/1:15
!
dial-peer voice 10 pots
translation-profile incoming IN-MTS
translation-profile outgoing OUT-MTS
destination-pattern 1....
direct-inward-dial
port 0/1/0:15
forward-digits all
!
dial-peer voice 202 voip
translation-profile outgoing TOCCM
preference 1
destination-pattern 2...
session target ipv4:192.168.10.5
dtmf-relay h245-alphanumeric
codec g711ulaw
no vad
!
dial-peer voice 203 voip
translation-profile outgoing TOCCM
preference 2
destination-pattern 2...
session target ipv4:192.168.10.6
dtmf-relay h245-alphanumeric
codec g711ulaw
no vad
!
dial-peer voice 204 voip
translation-profile outgoing TOCCM
preference 1
destination-pattern 3...
session target ipv4:192.168.10.5
dtmf-relay h245-alphanumeric
codec g711ulaw
no vad
!
dial-peer voice 205 voip
translation-profile outgoing TOCCM
preference 2
destination-pattern 3...
session target ipv4:192.168.10.6
dtmf-relay h245-alphanumeric
codec g711ulaw
no vad
!
dial-peer voice 206 voip
translation-profile outgoing TOCCM
preference 1
destination-pattern 4...
session target ipv4:192.168.10.5
dtmf-relay h245-alphanumeric
codec g711ulaw
no vad
!
dial-peer voice 207 voip
translation-profile outgoing TOCCM
preference 2
destination-pattern 4...
session target ipv4:192.168.10.6
dtmf-relay h245-alphanumeric
codec g711ulaw
no vad
!
dial-peer voice 11 pots
translation-profile incoming IN-MTS
translation-profile outgoing OUT-MTS
destination-pattern 19.........
direct-inward-dial
port 0/1/0:15
forward-digits all
!
dial-peer voice 9 pots
description Line for Test 4001
translation-profile incoming IN
incoming called-number 7975663
direct-inward-dial
port 0/0/1:15
!
dial-peer voice 208 voip
translation-profile outgoing TOCCM
preference 1
destination-pattern 88..
session target ipv4:192.168.10.5
dtmf-relay h245-alphanumeric
codec g711ulaw
no vad
!
dial-peer voice 209 voip
translation-profile outgoing TOCCM
preference 2
destination-pattern 88..
session target ipv4:192.168.10.6
dtmf-relay h245-alphanumeric
codec g711ulaw
no vad
!
dial-peer voice 50100 voip
preference 1
destination-pattern 501..
session target ipv4:10.137.1.1
no vad
!
dial-peer voice 12 pots
description Test outgoing through ALFA
translation-profile outgoing OUT-ALFA
destination-pattern 6T
port 0/0/1:15
forward-digits all
!
gateway
timer receive-rtp 1200
!
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
access-class 10 in
exec-timeout 30 0
logout-warning 60
absolute-timeout 30
login local
transport input telnet
line vty 5 15
access-class 10 in
exec-timeout 30 0
logout-warning 60
absolute-timeout 30
login local
transport input telnet
!
scheduler allocate 20000 1000
ntp clock-period 17179965
ntp update-calendar
ntp server 172.27.1.1 source GigabitEthernet0/0 prefer
!
end
Последний раз редактировалось msotnikov Ср мар 24, 2010 4:04 pm, всего редактировалось 2 раз(а).
msotnikov
Постоянный визитер
 
Сообщения: 47
Зарегистрирован: Вт авг 25, 2009 9:44 am
Карма: + 0 -

Re: Cisco 3825 VoIP

Сообщение inf22 » Чт авг 27, 2009 9:05 am

На 3825, добавил следующее:
!
voice translation-rule 9
rule 1 /^6\(.*\)/ /3630118,,пин-код,\1/
!
voice translation-profile OUT-ALFA
translate called 9
!
dial-peer voice 12 pots
description Test outgoing through ALFA
translation-profile outgoing OUT-ALFA
destination-pattern 6T
port 0/0/1:15
forward-digits all


Вообще то для исходящего звонка используется dial-peer voice [TAG] voip а pots заварачивает твой звонок обратоно в порт
inf22
Специалист
 
Сообщения: 105
Зарегистрирован: Чт авг 27, 2009 8:39 am
Карма: + 0 -

Re: Cisco 3825 VoIP

Сообщение msotnikov » Пн авг 31, 2009 9:47 am

А как же тогда
dial-peer voice 100 pots
description Outgoing Dial-peer for 7975662
translation-profile outgoing OUT
destination-pattern 9T
port 0/0/0:15
forward-digits all
!
Это же для выхода наружу и работает.
В дополнение, дебаг звонка
Aug 31 06:07:57.335: ISDN Se0/0/0:15 Q931: RX <- RELEASE pd = 8 callref = 0xA818
Aug 31 06:07:57.335: ISDN Se0/0/0:15 Q931: TX -> RELEASE_COMP pd = 8 callref = 0x2818
Aug 31 06:08:10.780: ISDN Se0/0/0:15 Q931: Applying typeplan for sw-type 0x12 is 0x0 0x0, Calling num 3605
Aug 31 06:08:10.780: ISDN Se0/0/0:15 Q931: Applying typeplan for sw-type 0x12 is 0x0 0x0, Called num 3630118,,123456789091662789
Aug 31 06:08:10.780: ISDN Se0/0/0:15 Q931: TX -> SETUP pd = 8 callref = 0x2821
Bearer Capability i = 0x8090A3
Standard = CCITT
Transfer Capability = Speech
Transfer Mode = Circuit
Transfer Rate = 64 kbit/s
Channel ID i = 0xA1839B
Preferred, Channel 27
Calling Party Number i = 0x0081, '3605'
Plan:Unknown, Type:Unknown
Called Party Number i = 0x80, '3630118,,12345678909'
Plan:Unknown, Type:Unknown
Aug 31 06:08:10.848: ISDN Se0/0/0:15 Q931: RX <- RELEASE_COMP pd = 8 callref = 0xA821
Cause i = 0x82E470 - Invalid information element contents

Особенно интересует строка
Called Party Number i = 0x80, '3630118,,12345678909'

номер передает не полностью.
ПОЧЕМУ?
=======
Добавил в
voice translation-profile OUT-ALFA
translate calling 4
translate called 9

Теперь новая ошибка в дебаге:

Aug 31 14:16:10.016: ISDN Se0/0/1:15 Q931: Applying typeplan for sw-type 0x12 is 0x0 0x0, Calling num 7975665
Aug 31 14:16:10.020: ISDN Se0/0/1:15 Q931: Applying typeplan for sw-type 0x12 is 0x0 0x0, Called num 3630118,,123456789091662789
Aug 31 14:16:10.020: ISDN Se0/0/1:15 Q931: TX -> SETUP pd = 8 callref = 0x31CC
Bearer Capability i = 0x8090A3
Standard = CCITT
Transfer Capability = Speech
Transfer Mode = Circuit
Transfer Rate = 64 kbit/s
Channel ID i = 0xA1839F
Preferred, Channel 31
Calling Party Number i = 0x0081, '7975665'
Plan:Unknown, Type:Unknown
Called Party Number i = 0x80, '3630118,,12345678909'
Plan:Unknown, Type:Unknown
Aug 31 14:16:10.116: ISDN Se0/0/1:15 Q931: RX <- RELEASE_COMP pd = 8 callref = 0xB1CC
Cause i = 0x8181 - Unallocated/unassigned number

Номер, по прежнему набирается не весь.
msotnikov
Постоянный визитер
 
Сообщения: 47
Зарегистрирован: Вт авг 25, 2009 9:44 am
Карма: + 0 -

Re: Cisco 3825 VoIP

Сообщение citius » Ср сен 02, 2009 9:16 pm

попробуйте такой диал-пир.
трансляция не нужна.

dial-peer voice 12 pots
description Test outgoing through ALFA
destination-pattern 6T
port 0/0/1:15
prefix 3630118,,пин-код
Аватара пользователя
citius
Постоянный визитер
 
Сообщения: 23
Зарегистрирован: Ср окт 01, 2008 3:35 pm

Re: Cisco 3825 VoIP

Сообщение dyer » Чт сен 03, 2009 5:25 pm

такое
rule 1 /^6\(.*\)/ /3630118,,пин-код,\1/

сработает на аналоговых портах, но не будет работать на цифровых-для-голоса. вообще.
Подозреваю что циска не поддерживает на цифровых портах что-то типа "Send DTMF tones after voice call is answered"
dyer
Новичок
 
Сообщения: 15
Зарегистрирован: Чт авг 09, 2007 10:21 am

Re: Cisco 3825 VoIP

Сообщение msotnikov » Пн сен 07, 2009 10:51 am

citius писал(а):попробуйте такой диал-пир.
трансляция не нужна.

dial-peer voice 12 pots
description Test outgoing through ALFA
destination-pattern 6T
port 0/0/1:15
prefix 3630118,,пин-код



Спасибо за идею.
Попробовал. Но в таком случае, циска передает также и цифру 6 в Е1, что не требуется. Но это бы ладно. Она, по прежнему обрезает номер. То есть, передает еще четыре символа, после пинкода и режет. Передает 20 символов (вместе с запятыми) и все.
Где прописывается это ограничение?
msotnikov
Постоянный визитер
 
Сообщения: 47
Зарегистрирован: Вт авг 25, 2009 9:44 am
Карма: + 0 -

Re: Cisco 3825 VoIP

Сообщение ded » Пн сен 07, 2009 11:34 am

dial-peer voice 12 pots
description Test outgoing through ALFA
destination-pattern 6T
port 0/0/1:15
forward-digits all или
forward-digits last 6 уж тут поставьте сколько нужно
ded
Специалист
 
Сообщения: 4282
Зарегистрирован: Сб май 03, 2008 2:47 am

Re: Cisco 3825 VoIP

Сообщение citius » Пн сен 07, 2009 12:31 pm

msotnikov писал(а):
citius писал(а):попробуйте такой диал-пир.
трансляция не нужна.

dial-peer voice 12 pots
description Test outgoing through ALFA
destination-pattern 6T
port 0/0/1:15
prefix 3630118,,пин-код



Спасибо за идею.
Попробовал. Но в таком случае, циска передает также и цифру 6 в Е1, что не требуется. Но это бы ладно. Она, по прежнему обрезает номер. То есть, передает еще четыре символа, после пинкода и режет. Передает 20 символов (вместе с запятыми) и все.
Где прописывается это ограничение?

По идее на потсовых диалпирах автоматом должно отрезаться то что стоит перед Т.
Запятые уберите тогда, раз толку от них нет.

У вас там форвард-дигитс не установлен случайно? Попробуйте убрать или поиграть с его длиной, как тут советуют.

Блин под нету щас руками цифровых каналов, а то бы проверил.
--
signed by Citius
Аватара пользователя
citius
Постоянный визитер
 
Сообщения: 23
Зарегистрирован: Ср окт 01, 2008 3:35 pm

Re: Cisco 3825 VoIP

Сообщение citius » Пн сен 07, 2009 2:19 pm

Основной документ по данному вопросу:

http://www.cisco.com/en/US/docs/ios/voi ... _book.html
--
signed by Citius
Аватара пользователя
citius
Постоянный визитер
 
Сообщения: 23
Зарегистрирован: Ср окт 01, 2008 3:35 pm

Re: Cisco 3825 VoIP

Сообщение msotnikov » Ср сен 09, 2009 10:30 am

citius писал(а):Основной документ по данному вопросу:

http://www.cisco.com/en/US/docs/ios/voi ... _book.html



Спасибо. Прочитал я этот документ. Ничего, что помогло бы, не увидел.

forward-digits all, я прописывал.

dial-peer voice 12 pots
description Test outgoing through ALFA
translation-profile outgoing OUT-ALFA
destination-pattern 6T
port 0/0/1:15
forward-digits all

Запятые в translation-rule убирал.
Все бесполезно. :|

толку нет. Номер по-прежнему режется до 20-ти символов.
Последний раз редактировалось msotnikov Ср сен 09, 2009 10:41 am, всего редактировалось 1 раз.
msotnikov
Постоянный визитер
 
Сообщения: 47
Зарегистрирован: Вт авг 25, 2009 9:44 am
Карма: + 0 -

Re: Cisco 3825 VoIP

Сообщение sea1384 » Ср сен 09, 2009 10:34 am

у меня таже беда..режется номер
Код: Выделить всё
Sep  9 07:14:32.794: ISDN Se0/1/0:15 Q931: RX <- ALERTING pd = 8  callref = 0xD431
        Progress Ind i = 0x8488 - In-band info or appropriate now available
Sep  9 07:14:32.794: ISDN Se0/1/0:15 EVENT: process_rxstate: ces/callid 1/0xDDDA calltype 2 CALL_PROGRESS
Sep  9 07:14:33.098: ISDN Se0/1/0:15 EVENT: process_pri_call: call id 0xDDDB, number 992101хх,,416хххх#98926536ХХХХ, Guid 00E2685ADF04, speed 0, call type VOICE, redial No, CSM call No, pdata Yes
Sep  9 07:14:33.098: ISDN Se0/1/0:15 Q931: Applying typeplan for sw-type 0x12 is 0x0 0x0, Calling num 4955105001
Sep  9 07:14:33.098: ISDN Se0/1/0:15 Q931: Applying typeplan for sw-type 0x12 is 0x0 0x0, Called num 992101хх,,416хххх#8926536ХХХХ
Sep  9 07:14:33.098: ISDN Se0/1/0:15 Q931: TX -> SETUP pd = 8  callref = 0x5432
        Bearer Capability i = 0x8090A3
                Standard = CCITT
                Transfer Capability = Speech 
                Transfer Mode = Circuit
                Transfer Rate = 64 kbit/s
        Channel ID i = 0xA98399
                Exclusive, Channel 25
        Calling Party Number i = 0x0081, '49551050ХХ'
                Plan:Unknown, Type:Unknown
        Called Party Number i = 0x80, '992101хх,,416ХХХХ#892'


давай вместе биться над траблой
Последний раз редактировалось sea1384 Ср сен 09, 2009 11:12 am, всего редактировалось 2 раз(а).
sea1384
Постоянный визитер
 
Сообщения: 21
Зарегистрирован: Пн сен 07, 2009 8:19 am
Карма: + 0 -

Re: Cisco 3825 VoIP

Сообщение msotnikov » Ср сен 09, 2009 10:43 am

sea1384 писал(а):у меня таже беда..режется номер
[code]Sep 9 07:14:32.794: ISDN Se0/1/0:15 Q931: RX <- ALERTING pd = 8 callref = 0xD431

давай вместе биться над траблой


Давайте. Я только за. Вот, только куда еще ломиться не знаю.
У вас получается 21 символ...

Да, no digit-strip тоже не помогает
msotnikov
Постоянный визитер
 
Сообщения: 47
Зарегистрирован: Вт авг 25, 2009 9:44 am
Карма: + 0 -

Re: Cisco - передача пин-кода при транзитном звонке IP->PSTN

Сообщение sea1384 » Ср сен 09, 2009 11:09 am

на самом деле у меня тоже 20ть просто я ошибся когда номер правил
Код: Выделить всё
Sep  9 07:57:23.000: ISDN Se0/1/0:15 EVENT: process_pri_call: call id 0xDEED, number 92101хх,,416хххх#892653620хх, Guid 00C33F56BC05, speed 0, call type VOICE, redial No, CSM call No, pdata Yes
Sep  9 07:57:23.000: ISDN Se0/1/0:15 Q931: Applying typeplan for sw-type 0x12 is 0x0 0x0, Calling num 4955105001
Sep  9 07:57:23.004: ISDN Se0/1/0:15 Q931: Applying typeplan for sw-type 0x12 is 0x0 0x0, Called num 92101хх,,416хххх#892653620хх
Sep  9 07:57:23.004: ISDN Se0/1/0:15 Q931: TX -> SETUP pd = 8  callref = 0x5544
        Bearer Capability i = 0x8090A3
                Standard = CCITT
                Transfer Capability = Speech 
                Transfer Mode = Circuit
                Transfer Rate = 64 kbit/s
        Channel ID i = 0xA98393
                Exclusive, Channel 19
        Calling Party Number i = 0x0081, '4955105001'
                Plan:Unknown, Type:Unknown
        Called Party Number i = 0x80, '92101хх,,416хххх#892'
                Plan:Unknown, Type:Unknown
sea1384
Постоянный визитер
 
Сообщения: 21
Зарегистрирован: Пн сен 07, 2009 8:19 am
Карма: + 0 -

Re: Cisco - передача пин-кода при транзитном звонке IP->PSTN

Сообщение msotnikov » Ср сен 09, 2009 1:44 pm

Вот это http://en.wikipedia.org/wiki/E.164
не объясняет ли все?
Хотя, там речь идет о 15-ти символах, а здесь 20.
msotnikov
Постоянный визитер
 
Сообщения: 47
Зарегистрирован: Вт авг 25, 2009 9:44 am
Карма: + 0 -

Re: Cisco - передача пин-кода при транзитном звонке IP->PSTN

Сообщение sea1384 » Ср сен 09, 2009 2:16 pm

Самое интересное, что в настройках пира максимальное число передава-х сомволов 32, ставишь all или 32 или сколько надо, а передается все равно 20-ть!!!

Код: Выделить всё
msk10vgw1(config-dial-peer)#forward-digits ?
  <0-32>  number of right-justified dialed digits to be forwarded
  all     forward all destination digits
  extra   extra dialed digits to be forwarded
sea1384
Постоянный визитер
 
Сообщения: 21
Зарегистрирован: Пн сен 07, 2009 8:19 am
Карма: + 0 -

Re: Cisco - передача пин-кода при транзитном звонке IP->PSTN

Сообщение sea1384 » Пт сен 11, 2009 10:30 am

Всем привет.
есть решение всем читать здесь http://www.certification.ru/cgi-bin/for ... d&id=35182
sea1384
Постоянный визитер
 
Сообщения: 21
Зарегистрирован: Пн сен 07, 2009 8:19 am
Карма: + 0 -

Re: Cisco - передача пин-кода при транзитном звонке IP->PSTN

Сообщение firebug » Пт сен 11, 2009 10:48 am

на всякий случай копирую решение:

JTR
Команда forward-digits extra inband была добавлена как enhancement после решения бага CSCdy20913 для интеграции CME/SRST с системами голосовой почты.
Может вызывать reload роутера из-за CSCsl60664.
Работает не на всех типах DSP, только с BRI/PRI интерфейсами, не поддерживает destination-pattern конструкции T и тип range [8-9].
Аватара пользователя
firebug
Администратор
 
Сообщения: 3337
Зарегистрирован: Пн фев 16, 2004 3:00 am

Re: Cisco - передача пин-кода при транзитном звонке IP->PSTN

Сообщение msotnikov » Пт сен 11, 2009 4:29 pm

Отлично.
Осталось чуть-чуть.
Теперь номер дальше пауз не набирается.
voice translation-rule 9
rule 1 /^6\(.*\)/ /3630118,,XXXXXXX\1/

voice translation-profile to_Alpha
translate called 9

dial-peer voice 102 voip
incoming called-number 689091234567
translation profile incoming to_Alpha

dial-peer voice 12 pots
destination-pattern 3630118.*
no digit-strip
forward-digits extra inband
port 0/0/1:15

-----------------------

Набираю номер 689091234567

VoGW#deb isdn q931 int s0/0/1:15

Sep 11 13:03:33.657: ISDN Se0/0/1:15 Q931: Applying typeplan for sw-type 0x12 is 0x0 0x0, Calling num 7777
Sep 11 13:03:33.657: ISDN Se0/0/1:15 Q931: Applying typeplan for sw-type 0x12 is 0x0 0x0, Called num 3630118
Sep 11 13:03:33.661: ISDN Se0/0/1:15 Q931: TX -> SETUP pd = 8 callref = 0x5FC9
Bearer Capability i = 0x8090A3
Standard = CCITT
Transfer Capability = Speech
Transfer Mode = Circuit
Transfer Rate = 64 kbit/s
Channel ID i = 0xA18397
Preferred, Channel 23
Calling Party Number i = 0x0081, '7777'
Plan:Unknown, Type:Unknown
Called Party Number i = 0x80, '3630118'
Plan:Unknown, Type:Unknown
Sep 11 13:03:33.749: ISDN Se0/0/1:15 Q931: RX <- RELEASE_COMP pd = 8 callref = 0xDFC9
Cause i = 0x8181 - Unallocated/unassigned number
Sep 11 13:03:34.425: ISDN Se0/0/1:15 Q931: RX <- ALERTING pd = 8 callref = 0xDFC8
Progress Ind i = 0x8488 - In-band info or appropriate now available
Sep 11 13:03:34.541: ISDN Se0/0/1:15 Q931: TX -> DISCONNECT pd = 8 callref = 0xFC94
Cause i = 0x8090 - Normal call clearing

-------------------

проверка test voice translation-rule 9 , отрабатывает правильно.

Почему, только до запятых набирает?

Если в translation-rule совсем убрать запятые и destination-pattern сделать
3630118..................
то - "соединение с данным номером не возможно. ... сообщение cisco unity"
msotnikov
Постоянный визитер
 
Сообщения: 47
Зарегистрирован: Вт авг 25, 2009 9:44 am
Карма: + 0 -

Re: Cisco - передача пин-кода при транзитном звонке IP->PSTN

Сообщение dyer » Пн сен 14, 2009 3:28 pm

msotnikov писал(а):Набираю номер 689091234567

Called Party Number i = 0x80, '3630118'
Plan:Unknown, Type:Unknown
Sep 11 13:03:33.749: ISDN Se0/0/1:15 Q931: RX <- RELEASE_COMP pd = 8 callref = 0xDFC9
Cause i = 0x8181 - Unallocated/unassigned number

С той стороны ничего не хотят знать про тот номер, что вы им прислали.

Почему, только до запятых набирает?
потому что сами попросили:
msotnikov писал(а):dial-peer voice 12 pots
forward-digits extra inband




msotnikov писал(а):Если в translation-rule совсем убрать запятые и destination-pattern сделать
3630118..................
то - "соединение с данным номером не возможно. ... сообщение cisco unity"

Добейтесь сначала того, что при звонке на нужный вам номер доступа вам ответил именно тот оператор (IVR) который нужен,
а не cisco unity.
dyer
Новичок
 
Сообщения: 15
Зарегистрирован: Чт авг 09, 2007 10:21 am

Re: Cisco - передача пин-кода при транзитном звонке IP->PSTN

Сообщение msotnikov » Пт сен 25, 2009 11:13 am

Спасибо всем.
Честно говоря, четкого представления, как именно это работает у меня по прежнему нет. Но, главное заработало.
Как я понял, смысл в том, что и не надо добиваться того, чтобы в дебаге был виден весь номер.
Видимо команда forward-digits extra inband, «допередает», что ли… остальную последовательность, после установление соединения.
А в destination-pattern должен быть, только PSTN номер.
В общем, итоговые правила таковы:
________________________________________
!
voice translation-rule 9
rule 1 /^6\(.*\)/ /93630118,,XXXXXXX\1/
!
voice translation-profile to_Alpha
translate called 9
!
dial-peer voice 102 voip
translation-profile incoming to_Alpha
incoming called-number ^689T
!
dial-peer voice 12 pots
destination-pattern 93630118
no digit-strip
port 0/0/1:15
forward-digits extra inband
!
________________________________________

И дебаг, при этом, выглядит так:
#############
Sep 14 14:34:54.034: ISDN Se0/0/1:15 Q931: Applying typeplan for sw-type 0x12 is 0x0 0x0, Calling num 7777
Sep 14 14:34:54.034: ISDN Se0/0/1:15 Q931: Applying typeplan for sw-type 0x12 is 0x0 0x0, Called num 93630118
Sep 14 14:34:54.034: ISDN Se0/0/1:15 Q931: TX -> SETUP pd = 8 callref = 0x6EDB
Bearer Capability i = 0x8090A3
Standard = CCITT
Transfer Capability = Speech
Transfer Mode = Circuit
Transfer Rate = 64 kbit/s
Channel ID i = 0xA1839F
Preferred, Channel 31
Calling Party Number i = 0x0081, '7777'
Plan:Unknown, Type:Unknown
Called Party Number i = 0x80, '93630118'
Plan:Unknown, Type:Unknown
Sep 14 14:34:54.142: ISDN Se0/0/1:15 Q931: RX <- CALL_PROC pd = 8 callref = 0xEEDB
Channel ID i = 0xA9839F
Exclusive, Channel 31
Sep 14 14:34:54.834: ISDN Se0/0/1:15 Q931: RX <- CONNECT pd = 8 callref = 0xEEDB
Sep 14 14:34:54.834: ISDN Se0/0/1:15 Q931: TX -> CONNECT_ACK pd = 8 callref = 0x6EDB
Sep 14 14:35:24.042: ISDN Se0/0/1:15 Q931: RX <- DISCONNECT pd = 8 callref = 0xEEDB
Cause i = 0x8190 - Normal call clearing
Sep 14 14:35:24.042: ISDN Se0/0/1:15 Q931: TX -> RELEASE pd = 8 callref = 0x6EDB
Sep 14 14:35:24.074: ISDN Se0/0/1:15 Q931: RX <- RELEASE_COMP pd = 8 callref = 0xEEDB
##########

Вроде работает.
msotnikov
Постоянный визитер
 
Сообщения: 47
Зарегистрирован: Вт авг 25, 2009 9:44 am
Карма: + 0 -

След.

Вернуться в Cisco

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 5

cron