транскодинг g729tog711

Обсуждение оборудования Cisco Systems

транскодинг g729tog711

Сообщение megahertz » Вт апр 02, 2013 1:35 pm

Добрый день, друзья
Прошу помощи с правкой конфига. пытаюсь транскодить из g729 в g711
Но все как то безуспелшно(пример конфига ниже)
Код: Выделить всё
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname ChelSIPGate
!
boot-start-marker
boot system flash c2800nm-ipvoice-mz.124-24.T5.bin
boot-end-marker
!
logging message-counter syslog
logging buffered 65536
no logging console
!
aaa new-model
!
!
aaa authentication login default local
aaa authorization exec default local
aaa authorization network default local
!
!
aaa session-id common
clock timezone EKT 6
!
ip source-route
!
!
ip cef
!
!
ip domain name ural.ocs.ru
ip name-server 192.168.224.5
ip name-server 192.168.224.35
ip name-server 192.168.228.18
no ipv6 cef
multilink bundle-name authenticated
!
!
!
!
!
!
voice service voip
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 no supplementary-service sip refer
 redirect ip2ip
 fax protocol pass-through g711alaw
 sip
  rel1xx disable
  header-passing
  error-passthru
  registrar server
!
!
!
voice class codec 1
 codec preference 1 g711ulaw
!
voice class codec 2
 codec preference 1 g729r8
 codec preference 2 g729br8
!
!
!
!
voice class sip-profiles 1
 request INVITE sip-header Diversion remove
!
!
!
!
!
!
!
!
!

voice translation-profile inGate
 translate called 4
!
voice translation-profile outGate
 translate calling 3
 translate called 2
!
!
voice-card 0
 dsp services dspfarm
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.228.20 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 172.16.174.6 255.255.255.252
 duplex auto
 speed auto
!
ip forward-protocol nd
ip route 172.30.246.13 255.255.255.255 172.16.174.5
ip route 192.168.0.0 255.255.0.0 192.168.228.1
!
!
no ip http server
!
ip access-list extended SIP-Input
 permit ip 192.168.0.0 0.0.255.255 host 192.168.228.20
ip access-list extended SIP-Output
 permit ip host 192.168.228.20 192.168.0.0 0.0.255.255
!
logging trap debugging
logging facility syslog
logging 192.168.224.212
logging 192.168.224.48
access-list 23 permit 192.168.228.0 0.0.1.255
access-list 23 permit 192.168.224.0 0.0.3.255
!
!
!
control-plane
!
!
!
!
!
sccp local FastEthernet0/0
sccp ccm 192.168.228.19 identifier 1 version 3.1
sccp
!
sccp ccm group 1
 associate ccm 1 priority 1
 associate profile 1 register ORANGE
!
dspfarm profile 1 transcode 
 codec g711ulaw
 codec g711alaw
 codec g729ar8
 codec g729abr8
 codec g729r8
 maximum sessions 6
 associate application SCCP
!
!
dial-peer voice 1 voip
 description Orange Direct SIP
 translation-profile outgoing outGate
 destination-pattern .+
 voice-class codec 2
 no voice-class sip early-offer forced
 session protocol sipv2
 session target ipv4:172.16.174.5
 session transport udp
 dtmf-relay rtp-nte sip-notify
 dtmf-interworking rtp-nte
 ip qos dscp cs3 media
 no vad
!
dial-peer voice 2 voip
 description Incoming Calls to Lync
 translation-profile outgoing inGate
 destination-pattern 7995369
 rtp payload-type comfort-noise 13
 voice-class codec 1
 session protocol sipv2
 session target ipv4:192.168.228.19:5060
 session transport tcp
 incoming called-number 7995369
 dtmf-relay rtp-nte
 ip qos dscp cs3 media
 ip qos dscp cs3 signaling
 no vad
!
dial-peer voice 1000 voip
 description To-Lync
 destination-pattern 1...
 rtp payload-type comfort-noise 13
 voice-class codec 1
 no voice-class sip early-offer forced
 session protocol sipv2
 session target ipv4:192.168.228.19:5060
 session transport tcp
 dtmf-relay rtp-nte sip-notify
 ip qos dscp cs3 media
 no vad
!
dial-peer voice 2000 voip
 description To-Lync
 destination-pattern 2...
 translate-outgoing called 1
 rtp payload-type comfort-noise 13
 voice-class codec 1
 no voice-class sip early-offer forced
 session protocol sipv2
 session target ipv4:192.168.228.19:5060
 session transport tcp
 dtmf-relay rtp-nte
 ip qos dscp cs3 media
 no vad
!
dial-peer voice 3000 voip
 description To-Lync
 destination-pattern 3...
 translate-outgoing called 1
 rtp payload-type comfort-noise 13
 voice-class codec 1
 no voice-class sip early-offer forced
 session protocol sipv2
 session target ipv4:192.168.228.19:5060
 session transport tcp
 dtmf-relay rtp-nte sip-notify
 ip qos dscp cs3 media
 no vad
!
dial-peer voice 4000 voip
 description To-Lync
 destination-pattern 4...
 translate-outgoing called 1
 rtp payload-type comfort-noise 13
 voice-class codec 1
 no voice-class sip early-offer forced
 session protocol sipv2
 session target ipv4:192.168.228.19:5060
 session transport tcp
 dtmf-relay rtp-nte sip-notify
 ip qos dscp cs3 media
 no vad
!
dial-peer voice 5000 voip
 description To-Lync
 destination-pattern 5...
 translate-outgoing called 1
 rtp payload-type comfort-noise 13
 voice-class codec 1
 no voice-class sip early-offer forced
 session protocol sipv2
 session target ipv4:192.168.228.19:5060
 session transport tcp
 dtmf-relay rtp-nte sip-notify
 ip qos dscp cs3 media
 no vad
!
dial-peer voice 6000 voip
 description To-Lync
 destination-pattern 6...
 rtp payload-type comfort-noise 13
 voice-class codec 1
 no voice-class sip early-offer forced
 session protocol sipv2
 session target ipv4:192.168.228.19:5060
 session transport tcp
 dtmf-relay rtp-nte sip-notify
 ip qos dscp cs3 media
 no vad
!
dial-peer voice 7000 voip
 description To-Lync
 destination-pattern 7...
 rtp payload-type comfort-noise 13
 voice-class codec 1
 no voice-class sip early-offer forced
 session protocol sipv2
 session target ipv4:192.168.228.19:5060
 session transport tcp
 dtmf-relay rtp-nte sip-notify
 ip qos dscp cs3 media
 no vad
!
!
gateway
 timer receive-rtp 1200
!
!
telephony-service
 sdspfarm units 1
 sdspfarm transcode sessions 10
 sdspfarm tag 1 ORANGE
 ip source-address 192.168.228.20 port 2000
 max-conferences 8 gain -6
 transfer-system full-consult
 create cnf-files version-stamp Jan 01 2002 00:00:00
!
alias exec sipt show sip-ua connections tcp detail
alias exec sipu show sip-ua connections udp detail
alias exec sib show ip int brief
alias exec psc sh proc cpu | excl 0.00%__0.00%__0.00%
!
line con 0
line aux 0
line vty 0 4
 session-timeout 600
 access-class 23 in
 exec-timeout 600 0
 privilege level 15
 transport input telnet
line vty 5 15
 session-timeout 600
 access-class 23 in
 exec-timeout 600 0
 privilege level 15
 transport input telnet
!
scheduler allocate 20000 1000
ntp server 195.64.192.35
ntp server 62.33.99.241
end


Router#sh sdspfarm units

mtp-1 Device:ORANGE TCP socket:[-1] UNREGISTERED


Router#sh sccp
SCCP Admin State: UP
Gateway IP Address: 192.168.228.19, Port Number: 2000
IP Precedence: 5
User Masked Codec list: None
Call Manager: 192.168.228.19, Port Number: 2000
Priority: N/A, Version: 3.1, Identifier: 1

Transcoding Oper State: ACTIVE_IN_PROGRESS - Cause Code: TCP_CONN_ERROR
Active Call Manager: NONE
TCP Link Status: NOT_CONNECTED, Profile Identifier: 1
Reported Max Streams: 10, Reported Max OOS Streams: 0
megahertz
Новичок
 
Сообщения: 4
Зарегистрирован: Вт апр 02, 2013 1:12 pm
Карма: + 0 -

Re: транскодинг g729tog711

Сообщение firebug » Вт апр 02, 2013 1:45 pm

в telephony-service добавьте
max-dn
max-ephone

версию в "sccp ccm 192.168.228.19 identifier 1 version 3.1 " поставьте повыше, как минимум 4, лучше 7
Аватара пользователя
firebug
Администратор
 
Сообщения: 3369
Зарегистрирован: Пн фев 16, 2004 3:00 am

Re: транскодинг g729tog711

Сообщение megahertz » Вт апр 02, 2013 3:08 pm

точно, спасибо за помощь
megahertz
Новичок
 
Сообщения: 4
Зарегистрирован: Вт апр 02, 2013 1:12 pm
Карма: + 0 -

Re: транскодинг g729tog711

Сообщение megahertz » Чт апр 04, 2013 10:24 am

Всем привет еще раз. к сожалению на момент прошлого поста все окончательно проверить возможности не было.
Прикладываю дебаг во время звонка
Код: Выделить всё
*Apr  4 03:55:54.612: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
SIP/2.0 488 Not Acceptable Media
Via: SIP/2.0/TCP 192.168.228.19:51785;branch=z9hG4bK55226c74
From: "159test"<sip:+5539@xxx.ru;user=phone>;epid=DD757BDCC2;tag=8ff7c87ddd
To: <sip:92822021@192.168.228.20;user=phone>;tag=F4C5FBB8-17CD
Date: Thu, 04 Apr 2013 03:55:54 GMT
Call-ID: 1171c1e9-0bbb-487e-a60b-934010d6fa5d
CSeq: 14010 INVITE
Allow-Events: telephone-event
Warning: 304 192.168.228.20 "Media Type(s) Unavailable"
Reason: Q.850;cause=65
Server: Cisco-SIPGateway/IOS-12.x
Content-Length: 0
 
 
*Apr  4 03:55:54.636: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
ACK sip:92822021@192.168.228.20;user=phone SIP/2.0
FROM: "159test"<sip:+5539@xxx.ru;user=phone>;tag=8ff7c87ddd;epid=DD757BDCC2
TO: <sip:92822021@192.168.228.20;user=phone>;tag=F4C5FBB8-17CD
CSEQ: 14010 ACK
CALL-ID: 1171c1e9-0bbb-487e-a60b-934010d6fa5d
MAX-FORWARDS: 70
VIA: SIP/2.0/TCP 192.168.228.19:51785;branch=z9hG4bK55226c74
CONTENT-LENGTH: 0


Где то читал что траблы в кодеках, но...
megahertz
Новичок
 
Сообщения: 4
Зарегистрирован: Вт апр 02, 2013 1:12 pm
Карма: + 0 -

Re: транскодинг g729tog711

Сообщение ded » Чт апр 04, 2013 11:35 am

Вы приводите ответ SIP/2.0 488 Not Acceptable Media на CSeq: 14010 INVITE

А надо видеть сам пакет INVITE, особенно его sdp часть, где информация о запрашиваемых кодеках.
ded
Специалист
 
Сообщения: 4029
Зарегистрирован: Сб май 03, 2008 2:47 am

Re: транскодинг g729tog711

Сообщение megahertz » Чт апр 04, 2013 12:06 pm

Код: Выделить всё
Вывод дебага:
ChelSIPGate#deb ccsip messages
SIP Call messages tracing is enabled
ChelSIPGate#term mon
*Apr  4 03:55:54.600: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
INVITE sip:92822021@192.168.228.20;user=phone SIP/2.0
FROM: "159test"<sip:+5539@xxx.ru;user=phone>;epid=DD757BDCC2;tag=8ff7c87ddd
TO: <sip:92822021@192.168.228.20;user=phone>
CSEQ: 14010 INVITE
CALL-ID: 1171c1e9-0bbb-487e-a60b-934010d6fa5d
MAX-FORWARDS: 70
VIA: SIP/2.0/TCP 192.168.228.19:51785;branch=z9hG4bK55226c74
CONTACT: <sip:xxx.ru:5060;transport=Tcp;maddr=192.168.228.19;ms-opaque=641981a6efd49f47>
CONTENT-LENGTH: 345
SUPPORTED: 100rel
USER-AGENT: RTCC/4.0.0.0 MediationServer
CONTENT-TYPE: application/sdp
ALLOW: ACK
Allow: CANCEL,BYE,INVITE,PRACK,UPDATE
 
v=0
o=- 58 1 IN IP4 192.168.228.19
s=session
c=IN IP4 192.168.228.19
b=CT:1000
t=0 0
m=audio 49672 RTP/AVP 97 101 13 0 8
c=IN IP4 192.168.228.19
a=rtcp:49673
a=label:Audio
a=sendrecv
a=rtpmap:97 RED/8000
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-16
a=rtpmap:13 CN/8000
a=rtpmap:0 PCMU/8000
a=rtpmap:8 PCMA/8000
a=ptime:20
 
megahertz
Новичок
 
Сообщения: 4
Зарегистрирован: Вт апр 02, 2013 1:12 pm
Карма: + 0 -

Re: транскодинг g729tog711

Сообщение ded » Чт апр 04, 2013 12:21 pm

Ответ SIP/2.0 488 Not Acceptable Media идёт на предложение кодека
a=rtpmap:13 CN/8000 я про такой не знаю, скорее всего это comfort noise, и Cisco видать тоже, потому так отвечает. Попробуйте убрать его на устройстве, которе посылает инвайт.

Это не утверждение, это версия.
ded
Специалист
 
Сообщения: 4029
Зарегистрирован: Сб май 03, 2008 2:47 am

Re: транскодинг g729tog711

Сообщение Keffer » Пн авг 06, 2018 10:02 am

По поводу 729 кодека вопросик. Телефонный аппарат Cisco 7962. В настройках конфига стоит preferred_codec: g711ulaw, при вызове на аппарат с кодеком preferred_codec: g729 естественно звук не проходит. Как в настройках указать цискофону, что если на вызываемой стороне поддерживается только 729 кодек то и вызов делать с помощью 729 кодека?

А так по дефолту используя опцию preferred_codec: g711ulaw сискофон делает исходящие исключительно с этого кодека. В voip шлюзах linksys это просто решается там можно выбрать 3 поддерживаемых кодека и Use only preferred codec выставить "NO" тогда исход звонки совершаются с того что выставлено в preferred_codec, а входящие \исходящие берутся в Secondary или Third кодеках если preffered не совпал.
Keffer
Новичок
 
Сообщения: 10
Зарегистрирован: Пн мар 19, 2018 8:06 am
Карма: + 0 -

Re: транскодинг g729tog711

Сообщение ded » Пн авг 06, 2018 11:16 am

В большинстве программных АТС приоритет кодека при инвайте задаётся самой станцией, а не отдаётся на откуп конечным устройствам. Потому что в случае несовпадения preferred_codec станция может транскодить, а телефон - нет. Посмотрите на пакет INVITE - какой он прибегает на станцию от телефона (в sdp должно быть не менее трёх кодеков по вашему желанию -
a=rtpmap:0 PCMU/8000
a=rtpmap:8 PCMA/8000
a=rtpmap:18 G729/8000
Тогда на станции можно указать приоритет использования кодеков и/или транскодить из g711ulaw в g729.
ded
Специалист
 
Сообщения: 4029
Зарегистрирован: Сб май 03, 2008 2:47 am

Re: транскодинг g729tog711

Сообщение Maxim S. Denisov » Пн авг 06, 2018 8:23 pm

Кодеки задаются в System -> Region information -> Audio codec preference list, потом этот лист привязываете к региону в соседнем пункте меню.
Maxim Denisov
CXNi
Аватара пользователя
Maxim S. Denisov
Специалист
 
Сообщения: 1541
ICQ: 14246982
Зарегистрирован: Ср мар 25, 2009 11:18 am
Откуда: Moscow

Re: транскодинг g729tog711

Сообщение Keffer » Вт авг 07, 2018 4:40 am

Maxim S. Denisov писал(а):Кодеки задаются в System -> Region information -> Audio codec preference list, потом этот лист привязываете к региону в соседнем пункте меню.

Извините, не совсем понял как это делается. В конфигурационном файле цискофона как это можно сделать?

ded писал(а):Тогда на станции можно указать приоритет использования кодеков и/или транскодить из g711ulaw в g729.

Да, похоже вы правы, в моем случае приоритетом управляет действительно станция, руками выставляется приоритетный кодек.
Keffer
Новичок
 
Сообщения: 10
Зарегистрирован: Пн мар 19, 2018 8:06 am
Карма: + 0 -

Re: транскодинг g729tog711

Сообщение Maxim S. Denisov » Вт авг 07, 2018 10:40 am

Keffer писал(а):Извините, не совсем понял как это делается. В конфигурационном файле цискофона как это можно сделать?

Это делается в веб интерфейсе UCM который в свою очередь генерит конфиг для телефонов. Только о регионах телефон ничего не знает, за него это решает UCM.
Maxim Denisov
CXNi
Аватара пользователя
Maxim S. Denisov
Специалист
 
Сообщения: 1541
ICQ: 14246982
Зарегистрирован: Ср мар 25, 2009 11:18 am
Откуда: Moscow

Re: транскодинг g729tog711

Сообщение Keffer » Вт авг 07, 2018 10:46 am

У меня, извините, не UCM а перешитый в sip цискофон который подтягивает конфиг в xml с TFT сервера на asterisk
Keffer
Новичок
 
Сообщения: 10
Зарегистрирован: Пн мар 19, 2018 8:06 am
Карма: + 0 -

Re: транскодинг g729tog711

Сообщение Maxim S. Denisov » Вт авг 07, 2018 12:21 pm

Тогда смотрите на том устройстве где телефон зарегистрирован. Сам телефон о регионах ничего не знает и насколько я помню предлагает все умеемые кодеки.
Maxim Denisov
CXNi
Аватара пользователя
Maxim S. Denisov
Специалист
 
Сообщения: 1541
ICQ: 14246982
Зарегистрирован: Ср мар 25, 2009 11:18 am
Откуда: Moscow


Вернуться в Cisco

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1