Cisco unity express auto attendant

Обсуждение оборудования Cisco Systems

Cisco unity express auto attendant

Сообщение Caruso » Пн дек 11, 2017 9:17 am

Добрый день,

Хочу настроить Cisco Unity Express. Имеется маршрутизатор Cisco 2811.На нём версия ISO-a 15.1 ,версия Call manager-a 8.5 и модуль Cisco Unity Express версии 2.3. У меня проблема с AutoAttendant. Я захожу на web interface Cisco Unity Express, настраиваю default –skript ничего не изменяя.Только добавляю called number и operator extetion . Called number у меня номер 111,а номер оператора 104. После делаю звонок с городского номера, он у меня переводится на 111и IVR начинает проигрывать и говарит мне, если хочешь соединиться с оператором нажми 0, если хочешь набрать внутренний номер нажми 1 и так далее. Когда я набираю 0 у меня не идёт звонок на оператора. А когда набираю 1, а затем набираю внутренний номер, IVR проговаривает мною набранный номер, однако не звонит на extetion (на набранный номер телефона). В чём может быть проблема? Привожу вам ниже часть конфигурацию.



ip dhcp excluded-address 10.10.10.1
ip dhcp excluded-address 192.168.60.1
ip dhcp excluded-address 10.10.10.2
ip dhcp excluded-address 192.168.60.2
!
ip dhcp pool PHONE
network 192.168.60.0 255.255.255.0
default-router 192.168.60.1
option 150 ip 192.168.60.1
dns-server 62.212.235.201 185.43.190.40
!
ip dhcp pool DATA
network 10.10.10.0 255.255.255.0
default-router 10.10.10.1
dns-server 62.212.235.201 185.43.190.40



voice service voip
allow-connections sip to sip
sip
bind control source-interface FastEthernet0/0.20
bind media source-interface FastEthernet0/0.20
registrar server expires max 600 min 60
!
voice class codec 1
codec preference 1 g711alaw
codec preference 2 g711ulaw
codec preference 3 g729br8
!
!
voice register global
mode cme
source-address 192.168.60.1 port 5060
max-dn 10
max-pool 10
authenticate register
authenticate realm 192.168.60.1
tftp-path flash:
create profile sync 0004046417547332
!
voice register dn 1
number 200
name Adil Abishov
label Adil Abishov
!
voice register dn 2
number 201
call-forward b2bua busy 200
name Nazim Qurbanov
label Nazim Qurbanov



voice register pool 1
id mac 30F7.0D5F.5FCE
number 1 dn 1
cor incoming city default
voice-class codec 1
username test password 123456
no vad
!
voice register pool 2
id mac 000C.29F5.9641
number 1 dn 2
cor incoming mobil default
voice-class codec 1
username test1 password 123456
no vad
!
voice register pool 3
id mac 000C.29F5.1841
number 1 dn 3
voice-class codec 1
username test2 password 123456
no vad



!
voice translation-rule 1
rule 1 /xxxxxxxx/ /111/
!
voice translation-rule 2
rule 1 /^.*/ /xxxxxxxx/
!
!
voice translation-profile INC
translate called 1
!
voice translation-profile OUT
translate calling 2
!

interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 10.10.10.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
interface FastEthernet0/0.20
encapsulation dot1Q 20
ip address 192.168.60.1 255.255.255.0
!
interface Service-Engine0/0
ip unnumbered FastEthernet0/0.20
service-module ip address 192.168.60.2 255.255.255.0
service-module ip default-gateway 192.168.60.1
!
interface FastEthernet0/1
ip address dhcp
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
crypto map VPN_CLIENTS



!
ip nat inside source list 1 interface FastEthernet0/1 overload
ip route 0.0.0.0 0.0.0.0 FastEthernet0/1
ip route 93.88.80.64 255.255.255.248 93.88.80.94
ip route 192.168.60.2 255.255.255.255 Service-Engine0/0
!

!
dial-peer cor custom
name city
name international
name mobil
name local
!
!
dial-peer cor list city
member city
member local
!
dial-peer cor list mobil
member city
member mobil
member local
!
dial-peer cor list international
member city
member international
member mobil
member local
!
dial-peer cor list local
member local
!

!
dial-peer voice 1 voip
description **Incoming Call from SIP Trunk**
translation-profile incoming INC
session protocol sipv2
session target sip-server
incoming called-number .%
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
no vad
!
dial-peer voice 15 voip
corlist outgoing city
description To city
translation-profile outgoing OUT
destination-pattern [345]......
session protocol sipv2
session target ipv4:93.88.80.70
voice-class codec 1
dtmf-relay sip-notify rtp-nte
no vad
!
dial-peer voice 16 voip
corlist outgoing mobil
description To mobil
translation-profile outgoing OUT
destination-pattern 0[1-9]........
session protocol sipv2
session target ipv4:93.88.80.70
voice-class codec 1
dtmf-relay sip-notify rtp-nte
no vad
!

!
dial-peer voice 17 voip
corlist outgoing international
description To international
translation-profile outgoing OUT
destination-pattern 00.T
session protocol sipv2
session target ipv4:93.88.80.70
voice-class codec 1
dtmf-relay sip-notify rtp-nte
no vad
!
dial-peer voice 18 voip
corlist outgoing local
description To TEC_159
translation-profile outgoing OUT
destination-pattern 188
session protocol sipv2
session target ipv4:93.88.80.70
voice-class codec 1
dtmf-relay sip-notify rtp-nte
no vad
!
dial-peer voice 19 voip
corlist outgoing local
description To TEC_159
translation-profile outgoing OUT
destination-pattern 903
session protocol sipv2
session target ipv4:93.88.80.70
voice-class codec 1
dtmf-relay sip-notify rtp-nte
no vad
!

!
dial-peer voice 20 voip
corlist incoming local
service session
destination-pattern 111
session protocol sipv2
session target ipv4:192.168.60.2
dtmf-relay rtp-nte
codec g711ulaw
no vad
!
!
!
!
telephony-service
max-ephones 10
max-dn 10
ip source-address 192.168.60.1 port 2000
cnf-file location flash:
load 7911 SCCP11.8-3-3SR2S.loads
load 7970 SCCP70.8-5-3S.loads
voicemail 128
max-conferences 8 gain -6
web admin system name admin password xxxxxxxxxx
transfer-system full-consult
create cnf-files version-stamp 7960 Aug 25 2017 05:09:02
!

!
ephone-dn 1
number 100
label Anar Hashimov
name Anar Hashimov
corlist incoming international
!
!
ephone-dn 2 dual-line
number 101
label Vusal Gurbanov
name Vusal Gurbanov
!
!
ephone-dn 3 dual-line
number 102
label Rufat Heydarov
name Rufat Heydarov
!
!
ephone-dn 4 dual-line
number 103
label Yusif Aliyev
name Yusif Aliyev
call-forward busy 104
corlist incoming city
!

!
ephone 1
device-security-mode none
mac-address DC7B.94F8.2760
button 1:4
!
!
!
ephone 2
device-security-mode none
mac-address 0021.D8BA.66E0
button 1:5
!
!
!
ephone 3
device-security-mode none
mac-address 001E.F729.9C0C
button 1:1 2:2
!

!
scheduler allocate 20000 1000
ntp master 2
ntp update-calendar
ntp server 82.197.188.130
ntp server 62.117.76.138
ntp server 89.109.251.21 prefer
ntp server 89.109.251.22
ntp server 64.90.182.55
ntp server 88.147.254.228
ntp server 81.2.117.228
end
Caruso
Новичок
 
Сообщения: 5
Зарегистрирован: Пн дек 11, 2017 8:32 am
Карма: + 0 -

Re: Cisco unity express auto attendant

Сообщение Caruso » Чт дек 21, 2017 1:50 pm

Добрый день,

Проблема решилась.Теперь у меня новая проблема. Когда я звоню из городского номера к себе в офис, попадаю на IVR. Затем набираю внутренний номер, и если я после набранного номера не нажму решетку (#), звонок не пойдет. Какой параметр в скрипте или в настройке мне нужно изменить, чтобы у меня шёл звонок без решетки ? Заранее благодарен.
Caruso
Новичок
 
Сообщения: 5
Зарегистрирован: Пн дек 11, 2017 8:32 am
Карма: + 0 -

Re: Cisco unity express auto attendant

Сообщение firebug » Пт дек 22, 2017 7:13 am

без решетки звонок совсем не проходит или нужно ждать какое-то время после набора?
Аватара пользователя
firebug
Администратор
 
Сообщения: 3369
Зарегистрирован: Пн фев 16, 2004 3:00 am

Re: Cisco unity express auto attendant

Сообщение Caruso » Пт дек 22, 2017 7:53 am

Добрый день. Да без решетки звонок совсем не проходит.Жди не жди без разницы.
Caruso
Новичок
 
Сообщения: 5
Зарегистрирован: Пн дек 11, 2017 8:32 am
Карма: + 0 -

Re: Cisco unity express auto attendant

Сообщение Caruso » Пн дек 25, 2017 2:05 pm

Еще раз здравствуйте.

И эта проблема уже решена. Теперь у меня возникла еще одна проблема.После того как я настраиваю на Cisco Unity Express IVR и у меня всё нормально работает, я отсоединяю маршрутизатор от электричества и заново включаю у меня перестает работать IVR. Чтоб он заново заработал мне нужно через CLI зайти на интерфейс Cisco Unity Express. Tолько после этого IVR начинает работать.Kак можно поставить Cisco Unity Express на автозагрузку, чтобы при включении маршрутизатор Cisco Unity Express автоматически начал работать тоже? Заранее благодарен.
Caruso
Новичок
 
Сообщения: 5
Зарегистрирован: Пн дек 11, 2017 8:32 am
Карма: + 0 -


Вернуться в Cisco

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1